通达信持股空仓指标公式

2022-09-22 23:23:22    编辑:云才情小编   阅读:5次   点赞:2次
 VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
VAR3:=Sma(VAR2,3,1)-SMA(VAR1,9,1);
VAR4:=IF(VAR3>100,VAR3-100,0);
VAR5:=VAR4*2;
VAR6:=SMA(VAR5,2,1)-VAR5;
VAR7:=EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,13);
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=VAR8-VAR7;
VAR10:=SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,20,1);
VAR11:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR12:=SMA(VAR11,9,1)+100;
VAR13:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR14:=SMA(VAR13,3,1);
VAR15:=SMA(VAR14,3,1)+100;
VAR16:=VAR15-VAR12;
VAR17:=IF(VAR16>0,VAR16,0);
DRAWBAND(REF(VAR17,1),RGB(50,250,50),VAR17,RGB(250,100,50));
DRAWBAND(VAR7,RGB(250,20,20),VAR8,RGB(50,230,50));
DRAWBAND(SMA(VAR10,5,1),RGB(50,200,50),VAR10,RGB(250,50,250));
短线持股:IF(REF(VAR17,1)<VAR17,VAR17,DRAWNULL),NODRAW,COLORYELLOW;
中线持股:IF(VAR7-VAR8>0,VAR7,DRAWNULL),NODRAW,COLORRED;
长线持股:IF(VAR10-SMA(VAR10,5,1)>0,VAR10,DRAWNULL),NODRAW,COLORMAGENTA;
短线空仓:IF(REF(VAR17,1)>VAR17,VAR17,DRAWNULL),NODRAW,COLORGREEN;
中线空仓:IF(VAR7-VAR8<0,VAR7,DRAWNULL),NODRAW,COLORGREEN;
长线空仓:IF(VAR10-SMA(VAR10,5,1)<0,VAR10,DRAWNULL),NODRAW,COLORGREEN;

关键词:
免责声明:本文来自互联网,本站所有信息(包括但不限于文字、视频、音频、数据及图表),不保证该信息的准确性、真实性、完整性、有效性、及时性、原创性等,版权归属于原作者,如无意侵犯媒体或个人知识产权,请来电或致函告之,本站将在第一时间处理。云财情发布此文目的在于促进信息交流,不存在盈利性目的,此文观点与本站立场无关,不承担任何责任。未经证实的信息仅供参考,不做任何投资和交易根据,据此操作风险自担。侵权及不实信息举报邮箱至:amarlboro@yeah.net。