通达信KDJ操盘指标公式

2023-01-24 11:46:24    编辑:云才情小编   阅读:112次

通达信KDJ操盘指标公式

 {KDJ指标}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:Sma(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
{排短线决策}
DXJCNN:=IF(BARSCOUNT(C)>=8,5,BARSCOUNT(C));
DXJCAMOV:=vol*(C+L+H)/3;
DXJCMN:=SUM(DXJCAMOV,DXJCNN)/SUM(VOL,DXJCNN);
DXJC升:= C>=DXJCMN ;
DXJC降:= C<DXJCMN ;
stIckLINE (DXJC升,120,117,2,0),COLORYELLOW;
STICKLINE (DXJC降,120,117,2,0),COLORCYAN;
{第二排超级短线}
CJDXVAR1:=(2*CLOSE+HIGH+LOW)/4;
CJDXVAR2:=EMA(EMA(EMA(CJDXVAR1,4),4),4);
CJDXJJ:= (CJDXVAR2-REF(CJDXVAR2,1))/REF(CJDXVAR2,1)*100;
CJDXDD:= MA(CJDXJJ,3);
CJDXKK:= MA(CJDXJJ,1);
CJDX升:=CJDXKK>CJDXDD;
CJDX降:=CJDXDD>CJDXKK;
STICKLINE (CJDX升,113,110,2,0),COLORYELLOW;
STICKLINE (CJDX降,113,110,2,0),COLORCYAN;
{小浪底}
XLD_01:=5;
XLD_02:=EMA(CLOSE,XLD_01);
XLD_03:=EMA(XLD_02,XLD_01);
XLD_04:=XLD_02 - REF(XLD_02,1);
XLD_05:=XLD_03 - REF(XLD_03,1);
XLD_06:= Abs(XLD_02 - XLD_03);
XLD_07:= (XLD_04+XLD_05)/2;
XLD_08:= POW(XLD_06,1)*POW(XLD_07,3);
XLD_09:=XLD_08/HHV(ABS(XLD_08),XLD_01*3);
XLD_10:=((MA(C,30)-L)/MA(C,60))*200;
XLD_11:=REF(CLOSE,1);
XLD_12:=SMA(MAX(CLOSE-XLD_11,0),7,1)/SMA(ABS(CLOSE-XLD_11),7,1)*100;
XLD_13:=FILTER(REF(XLD_12,1)<20 AND XLD_12>REF(XLD_12,1),5);
XLD_14:=CLOSE/MA(CLOSE,40)<0.74;
XLD_15:=(HIGH-LOW)/REF(CLOSE,1)>0.05;
XLD_16:=COUNT(XLD_15,5)>1;
XLD_17:=XLD_14 AND XLD_15 AND XLD_16;
XLD_18:=FILTER((XLD_13 AND XLD_10>20 OR C>REF(CLOSE,1)) AND REF(XLD_17,1),10);
XLD_19:=CROSS(XLD_09,-0.9);
XLD_20:=FILTER(REF(XLD_17,1) AND (XLD_19 OR CLOSE>REF(C,1)) AND MACD.MACD>-1.5,10);
小浪底:=COUNT(XLD_20,13)>=1 AND XLD_18;
DRAWICON(小浪底,100,9);
DRAWTEXT(小浪底,90,' 小浪底'),COLORYELLOW;
{大浪底}
DLD_1:=(2*CLOSE+HIGH+LOW)/4;
DLD_2:=LLV(LOW,5);
DLD_3:=HHV(HIGH,5);
DLD_4:=EMA((DLD_1-DLD_2)/(DLD_3-DLD_2)*100,5);
DLD_5:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DLD_6:=SMA(DLD_5,3,1);
DLD_7:=SMA(DLD_6,3,1);
DLD_8:=3*DLD_6-2*DLD_7;
DLD_9:=DLD_8<(-10);
DLD_10:=REF(DLD_9,1)=1 AND DLD_9=0;
DLD_11:=OPEN=CLOSE AND CLOSE/REF(CLOSE,1)<0.902;
DLD_12:=MA(DLD_4,2);
DLD_13:=REF(CLOSE,1)/REF(CLOSE,2)<0.95;
DLD_14:=DLD_12<20 AND DLD_13 AND CLOSE>LOW AND OPEN>LOW;
DLD_15:=DLD_10 AND DLD_13 AND OPEN>LOW;
DLD_16:=REF(DLD_14,1)=1 AND REF(DLD_15,1)=0 AND LOW/MA(CLOSE,5)<0.97 AND NOT(COUNT(DLD_11,4)>0) AND LOW<REF(LOW,1);
DLD_18:=C-REF(C,1);
DLD_19:=100*EMA(EMA(DLD_18,6),6)/EMA(EMA(ABS(DLD_18),6),6);
DLD_20:=LLV(DLD_19,2)=LLV(DLD_19,7) AND COUNT(DLD_19<0,2) AND CROSS(DLD_19,MA(DLD_19,2));
大浪底:=DLD_16 AND DLD_20;
DRAWICON(大浪底,80,9);
DRAWTEXT(大浪底,70,' 大浪底'),COLORYELLOW;
{抄底宝}
CDB_1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
CDB_2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
CDB_3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,11)*100;
CDB_4:=CDB_1<-10 AND CDB_2<=-10 AND CDB_3<0;
CDB_5:=EMA(CLOSE,12)-EMA(CLOSE,150);
CDB_6:=EMA(CDB_5,9);
CDB_7:=(CDB_5-CDB_6)*2;
CDB_8:=CDB_7<0 AND CDB_7>REF(CDB_7,1) AND REF(CDB_7,1)<REF(CDB_7 ,2)
AND REF(CDB_7,2)<REF(CDB_7,3)
AND REF(CDB_7,3)<REF(CDB_7,4);
CDB_9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
CDB_10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
CDB_11:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
CDB_12:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
CDB_13:=(CDB_10+2*CDB_11+3*CDB_12)/6;
CDB_14:=MA(CDB_13,3);
CDB_15:=CDB_14<=-10;
CDB_16:=CLOSE/MA(CLOSE,20)*100<80;
CDB_17:=CLOSE/MA(CLOSE,40)*100<78;
CDB_18:=CLOSE/MA(CLOSE,60)*100<72;
CDB_19:=HIGH>LOW*1.051;
CDB_20:=CDB_19 AND COUNT(CDB_19,5)>1;
CDB_21:=CDB_20 AND (CDB_16 OR CDB_17 OR CDB_18);
CDB_22:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
CDB_23:=((REF(CDB_22,1)<REF(CDB_22,2) AND CDB_22<-30) AND CDB_22>=REF(CDB_22,1)) OR (REF(CROSS(-30,CDB_22),1) AND CROSS(CDB_22,-30)) OR CDB_22=-30;
CDB_24:=((REF(CDB_22,1)<REF(CDB_22,2) AND CDB_22<-20 AND CDB_22>-25) AND CDB_22>=REF(CDB_22,1)) OR (REF(CROSS(-20,CDB_22),1) AND CROSS(CDB_22,-20));
CDB_25:=CDB_24;
CDB_26:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
CDB_27:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
CDB_28:=SMA((CDB_27-50)*2,3,1)+SMA((CDB_26-50)*2,3,1)/2;
CDB_29:=CDB_28<-90;
抄底宝:=CDB_29 AND COUNT(CDB_25,5)>=1 AND COUNT(CDB_21,3)>=1 AND COUNT(CDB_4,3)>=1 AND CDB_15 AND CDB_8;
DRAWICON(抄底宝,60,16);
DRAWTEXT(抄底宝,50,' 抄底宝'),COLORYELLOW;
{大魔王}
MWA_1:=C<REF(C,4);
MWA_2:=DMA(CLOSE,VOL/SUM(VOL,34));
MWA_3:=DMA(CLOSE,VOL/SUM(VOL,13));
MWA_4:=(CLOSE-MWA_2)/MWA_2*100;
MWA_5:=(CLOSE-MWA_3)/MWA_3*100;
MWA_6:=BArslASTCOUNT(MWA_1);
MWA_7:=MWA_6=6 ;
MWA_8:=COUNT(MWA_6=6,5)=1;
MWA_9:=MWA_5<=-17 AND MWA_4<=-25;
MWA_10:=MWA_8 AND MWA_9 ;
MWA_11:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);
MWA_12:=MWA_11<-20;
魔王A:=MWA_10 AND MWA_12 AND C>REF(C,1)*0.91 AND C<REF(C,1)
AND INDEXC<REF(INDEXC,1) AND REF(C>REF(C,1),1);
MWB_1:=O/HHV(C,30)<0.78;
MWB_2:=C/MA(C,50)<0.78;
MWB_3:=O=LLV(O,30);
MWB_4:=C/SMA(C,13,1)-1;
MWB_5:=REF(MWB_4,1)<-0.13;
MWB_6:=REF(MWB_4,1)/MWB_4>1.1582;
MWB_7:=REF(C,1)<=COST(5);
MWB_8:=COUNT(H>L*1.05,5)>2;
魔王B:=MWB_1 AND MWB_2 AND MWB_3 AND MWB_5 AND MWB_6 AND MWB_7 AND MWB_8;
魔王C:=WINNER(C)*100<10 AND (WINNER(C*1.25)-WINNER(C))*100<20
AND C/REF(C,1)>1.0138 AND V/REF(V,1)<1;
MWD_1:=(CLOSE-SMA(CLOSE,7,1))/SMA(CLOSE,7,1)*(-100);
MWD_2:=REF(MWD_1,1)>13 AND REF(MWD_1,1)/MWD_1>1.3 AND CLOSE/REF(CLOSE,1)>1.03;
魔王D:=IF(MWD_2 AND REF(CLOSE,1)<=COST(5),1,0) AND C<MA(C,60);
MWE_1:=(C-MA(C,3))/MA(C,3)*100;
MWE_2:=V/CAPITAL*100;
MWE_3:=INDEXC;
MWE_4:=MA(MWE_3,5);
MWE_5:=MWE_4>1.05*MWE_3;
MWE_6:=(C-HHV(C,13))/HHV(C,13)*10;
MWE_7:=(C-REF(C,21))/REF(C,21)*10;
MWE_8:=MA(C,5);
MWE_9:=MWE_5;
MWE_10:=MWE_7<-2.30;
MWE_11:=MWE_1<-2.7;
MWE_12:=MWE_9 AND MWE_10 AND MWE_11;
MWE_13:=CROSS(0.55,MWE_12);
MWE_14:=CROSS(MWE_13,0.5);JS2:=BARSLAST(MWE_14=1);
MWE_15:=JS2<=5 AND C<REF(C,JS2);
MWE_16:=MWE_13 OR MWE_15;
魔王E:=BARSLASTCOUNT(REF(MWE_16,1))=1;
MWF_1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
MWF_2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
MWF_3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MWF_4:=(MWF_1+2*MWF_2+3*MWF_3)/6;
MWF_5:=MA(MWF_4,3);
MWF_6:=EMA(CLOSE,12)-EMA(CLOSE,150);
MWF_7:=EMA(MWF_6,9);
MWF_8:=(MWF_6-MWF_7)*2;
MWF_9:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2) AND REF(MWF_8,2)<REF(MWF_8,3) AND REF(MWF_8,3)
<REF(MWF_8,4);
MWF_10:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2) AND REF(MWF_8,2)<REF(MWF_8,3);
MWF_11:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2);
MWF_12:=MWF_9 OR MWF_10 OR MWF_11;
MWF_13:=MWF_12;
MWF_14:=CLOSE/MA(CLOSE,20)*100<80;
MWF_15:=CLOSE/MA(CLOSE,40)*100<78;
MWF_16:=CLOSE/MA(CLOSE,60)*100<72;
MWF_17:=HIGH>LOW*1.051;
MWF_18:=MWF_17 AND COUNT(MWF_17,5)>1;
MWF_19:=(MWF_14 AND MWF_15) OR (MWF_15 AND MWF_16) OR (MWF_14 AND MWF_16);
MWF_20:=MWF_18 AND MWF_19;
MWF_21:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
MWF_22:=((REF(MWF_21,1)<REF(MWF_21,2) AND MWF_21<-30) AND MWF_21>=REF(MWF_21,1)) OR (REF(CROSS(-30,MWF_21),1) AND CROSS(MWF_21,-30)) OR MWF_21=-30;
MWF_23:=((REF(MWF_21,1)<REF(MWF_21,2) AND MWF_21<-20 AND MWF_21>-25) AND MWF_21>=REF(MWF_21,1)) OR
(REF(CROSS(-20,MWF_21),1) AND CROSS(MWF_21,-20));
MWF_24:=MWF_23;
MWF_25:=MWE_4 AND MWF_13 AND COUNT(MWF_20,3)>=1 AND COUNT(MWF_24,5)>=1;
魔王F:=BARSLASTCOUNT(MWF_25)=1;
MWG_1:=C/MA(C,40)<0.80;
MWG_2:=EMA(C,2);
MWG_3:=EMA(MWG_2,1);
MWG_4:=MWG_2-REF(MWG_2,1);
MWG_5:=MWG_3-REF(MWG_3,1);
MWG_6:=ABS(MWG_2-MWG_3);
MWG_7:=(H-L)/REF(C,1)>0.05;
MWG_8:= (MWG_4+MWG_5)/2;
MWG_9:=POW(MWG_6,1)*POW(MWG_8,3);
MWG_10:=MWG_9/HHV(ABS(MWG_9),15);
MWG_11:=COUNT(MWG_7,5)>1;
MWG_12:=EMA(CLOSE,12)-EMA(CLOSE,26);
MWG_13:=EMA(MWG_12,9);
MWG_14:=(MWG_12-MWG_13)*2;
MWG_15:=MWG_1 AND MWG_11;
MWG_16:=CROSS(MWG_10,-0.9);
MWG_17:=FILTER(REF(MWG_15,1) AND (MWG_16 OR C>REF(C,1)) AND MWG_14>-0.58,10);
MWG_18:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
MWG_19:=MWG_18/2+22;
MWG_20:=(MWG_18+2)<MWG_19;
MWG_21:=(HIGH+LOW+CLOSE)/3;
MWG_22:=(MWG_21-MA(MWG_21,14))/(0.015*AVEDEV(MWG_21,14));
MWG_23:=MWG_20 AND COUNT(MWG_17,10)>=1 AND MWG_22>-108;
魔王G:=BARSLASTCOUNT(MWG_23)=1;
MWH_1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
MWH_2:=DMA(CLOSE,VOL/MA(VOL,32)/32);
MWH_3:=(CLOSE-MWH_1)/MWH_1*100<-8;
MWH_4:=(MWH_1-MWH_2)/MWH_2*100<-21;
MWH_5:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05;
MWH_6:=COUNT(NOT(C=O),8)>=8;
魔王H:=MWH_3 AND MWH_4 AND MWH_5 AND MWH_6;
MWI_1:=INDEXC/MA(INDEXC,58)<0.848 AND C/EMA(C,58)<0.81;
MWI_2:=BARSLAST(MWI_1)+1;
MWI_3:=BETWEEN(MWI_2,2,15) AND C<REF(C,MWI_2);
MWI_4:=COUNT(MWI_1,2) OR MWI_3;
魔王I:=FILTER(MWI_4,12);
MWJ_1:=(C-MA(C,90))/MA(C,90)*100;
MWJ_2:=(COST(11)-CLOSE)/CLOSE>0.15;
魔王J:=CROSS(MWJ_1,-26) AND MWJ_2;
MWK_1:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
MWK_2:=REF(MWK_1,1)>13 AND REF(MWK_1,1)/MWK_1>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
MWK_3:=EMA(CLOSE,24);
MWK_4:=EMA(MWK_3*80/100,5);
MWK_5:=(REF(MWK_4,1)>REF(C,1) AND C>MWK_4 AND C>REF(C,1)*1.02);
MWK_6:=C/SMA(C,13,1)-1;
MWK_7:=O/HHV(C,30)<0.78 AND C/MA(C,50)<0.78 AND O=LLV(O,30) AND REF(MWK_6,1)<-0.13
AND REF(MWK_6,1)/MWK_6>1.1582 AND REF(C,1)<=COST(5) AND COUNT(H>L*1.05,5)>2;
MWK_8:=MWK_2 AND REF(CLOSE,1)<=COST(5);
魔王K:=FILTER(MWK_5,3) OR MWK_7 OR MWK_8;
MWL_1:=EMA(CLOSE,3)-EMA(CLOSE,89);
MWL_2:=EMA(MWL_1,21);
MWL_3:=(MWL_1-MWL_2)*10;
MWL_4:=POW(MWL_3,3)*0.1+POW(MWL_3,2);
MWL_5:=IF(MWL_3>0.015,MWL_4,0)/45;
MWL_6:=MWL_5/REF(MWL_5,3)>1.5 AND MWL_5/REF(MWL_5,1)<1.196;
MWL_7:=IF(CLOSE>HHV(REF(HIGH,1),2),1,IF(CLOSE<LLV(REF(LOW,1),2),(-1),0));
MWL_8:=CROSS(MWL_7,0);
MWL_9:=CROSS(0,MWL_7);
MWL_10:=5;
MWL_11:=10;
MWL_12:=0.01*EMA(AMOUNT,MWL_10)/EMA(VOL,MWL_10);
MWL_13:=(MWL_12/REF(MWL_12,1)-1)*100;
MWL_14:=MA(MWL_13,MWL_11);
XA_9:=MWL_13<(-1.1) AND MWL_14<(-1.1);
MWL_15:=CROSS(MWL_13,MWL_14);
MWL_16:=XA_9 AND MWL_15;
MWL_17:=9;
MWL_18:=CLOSE-REF(CLOSE,1);
MWL_19:=100*EMA(EMA(MWL_18,MWL_17),MWL_17)/EMA(EMA(ABS(MWL_18),MWL_17),MWL_17);
MWL_20:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-
LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MWL_21:=REF(CLOSE,1);
MWL_22:=SMA(MAX(CLOSE-MWL_21,0),MWL_17,1)/SMA(ABS(CLOSE-MWL_21),MWL_17,1)*100;
MWL_23:=(CLOSE-REF(CLOSE,26))/REF(CLOSE,26)*10;
魔王L:=CROSS(MWL_22,20) AND MWL_19<(-45) AND MWL_20<12 AND MWL_23<(-2) AND MWL_16;
魔王:=魔王A+魔王B+魔王C+魔王D+魔王E+魔王F+魔王G+魔王H+魔王I+魔王J+魔王K+魔王L;
大魔王:=魔王>=3;
DRAWICON(大魔王,40,28);
DRAWTEXT(大魔王,30,' 大魔王'),COLORYELLOW;
{探底宝}
TDB_1:=IF(NAMELIKE(1),0,1);
TDB_2:=IF(NAMELIKE(2),0,1);
TDB_3:=IF(CODELIKE(3),0,1);
TDB_4:=TDB_1 AND TDB_2 AND TDB_3;
TDB_5:=MA(CLOSE,60);
TDB_6:=(CLOSE-TDB_5)/TDB_5*100;
TDB_7:=LLV(LOW,21);
TDB_8:=HHV(HIGH,21);
TDB_9:=EMA((CLOSE-TDB_7)/(TDB_8-TDB_7)*100,5);
TDB_10:=EMA((CLOSE-TDB_7)/(TDB_8-TDB_7)*50,13);
TDB_11:=CROSS(TDB_9,TDB_10);
TDB_12:=TDB_11=1;
TDB_13:=AMOUNT/VOL;
TDB_14:=LOW<TDB_13*0.9;
TDB_15:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
TDB_16:=LOW<MA(CLOSE,5)*0.921;
TDB_17:=VOL<MA(VOL,5)*1.5;
TDB_18:=SMA((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100,3,1);
TDB_19:=TDB_18<50;
TDB_20:=TDB_12 OR (TDB_14 AND TDB_15 AND TDB_16 AND TDB_17);
TDB_21:=TDB_4 AND TDB_19 AND TDB_20;
探底宝:=TDB_21 AND TDB_6<(-20) AND TDB_4;
DRAWICON(探底宝,20,18);
DRAWTEXT(探底宝,10,' 探底宝'),COLORYELLOW;

关键词: KDJ
免责声明:本文来自互联网,本站所有信息(包括但不限于文字、视频、音频、数据及图表),不保证该信息的准确性、真实性、完整性、有效性、及时性、原创性等,版权归属于原作者,如无意侵犯媒体或个人知识产权,请来电或致函告之,本站将在第一时间处理。云财情网站发布此文目的在于促进信息交流,不存在盈利性目的,此文观点与本站立场无关,不承担任何责任。未经证实的信息仅供参考,不做任何投资和交易根据,据此操作风险自担。侵权及不实信息举报邮箱至:amarlboro@yeah.net。

猜你喜欢

短线做T技巧-MACD、MA、KDJ、成交量等指标做T+0操作
主力出货时期的KDJ指标形态分析-J线高位钝化后快速下行形态
主力清理浮筹时期的KDJ指标形态分析-重回50线以下的KDJ金叉形态 ...
周线KDJ与月线KDJ的看法及使用技巧
KDJ指标的低位高强度钝化后的更佳买点
如何用KDJ指标分析震荡形态的股票走势
主力洗盘时期的KDJ指标形态分析-50线上的KDJ“死叉不死”形态 ...
日周月KDJ指标的综合应用技巧
KDJ指标高位钝化现象及买卖点判定