通达信天狼资金线指标公式

2022-04-23 00:32:23    编辑:云才情小编   阅读:5次   点赞:2次
 X_1:=100;
X_2:=90;
X_3:=80;
X_4:=50;
X_5:=10;
stICKLINE(X_1,100,100,4.2,0),COLORBROWN;
STICKLINE(X_2,90,90,0.5,0),COLORLICYAN;
STICKLINE(X_3,80,80,4.2,0),POINTDOT,COLORBROWN;
STICKLINE(X_5,0,5,4.2,0),LINESTICK,COLOR4D4D4D;
X_6:=REF(LOW,1);
X_7:=SMA(Abs(LOW-X_6),3,1)/Sma(MAX(LOW-X_6,0),3,1)*100;
X_8:=EMA(IF(CLOSE*1.3,X_7*10,X_7/10),3);
X_9:=LLV(LOW,30);
X_10:=HHV(X_8,30);
X_11:=IF(MA(CLOSE,58),1,0);
X_12:=EMA(IF(LOW<=X_9,(X_8+X_10*2)/2,0),3)/999*X_11;
X_13:=IF(X_12>100,100,X_12);
STICKLINE(X_13>0,0,X_13*1.2,3,0),COLORBROWN;
STICKLINE(X_13>0,0,X_13*1.2,2,0),COLOR00B0B0;
STICKLINE(X_13>0,0,X_13*1.2,0.8,0),COLOR00D2D2;
X_14:=3;
X_15:=3;
X_16:=3;
X_17:=2;
X_18:=SMA(IF(CLOSE>REF(CLOSE,1),CLOSE-REF(CLOSE,1),0),X_14,1);
X_19:=SMA(IF(CLOSE<=REF(CLOSE,1),ABS(CLOSE-REF(CLOSE,1)),0),X_14,1);
X_20:=100*X_18/(X_18+X_19);
X_21:=EMA(X_20,3);
背离' >底背离买卖线:EMA(X_21,3),COLORLIMAGENTA,LINETHICK2;
X_22:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
实时主力线:SMA(X_22,7,1),COLORWHITE;
机构线:SMA(SMA(X_22,7,1),3,1),COLORYELLOW;
散户线:SMA(SMA(X_22,7,1),7,1),COLOR80FF00;
X_23:=EMA(X_21,3);
X_24:=99;
X_25:=80;
X_26:=5;
X_27:=(CLOSE-LLV(LOW,X_15))/(HHV(HIGH,X_15)-LLV(LOW,X_15))*100;
X_28:=SMA(X_22,X_16,1);
X_29:=EMA(X_28,X_17);
X_30:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_31:=REF(EMA(X_30,3),1);
X_32:=vol/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_33:=IF(CLOSE>OPEN,X_32*(HIGH-LOW),IF(CLOSE<OPEN,X_32*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-X_32*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-X_32*(HIGH-LOW),0-VOL/2));
X_34:=X_33/20/1.15;
X_35:=X_34*0.55+REF(X_34,1)*0.33+REF(X_34,2)*0.22;
X_36:=EMA(X_35,2);
X_37:=X_36/1000;
X_38:=50;
蓝色卖出:IF(X_21<X_23 AND X_29<REF(X_29,1) AND X_37<=0,50,DRAWNULL AND MA(CLOSE,3)<REF(MA(CLOSE,3),1)),NODRAW,COLORBLUE,LINETHICK3;
减仓:IF(X_21>=X_23 AND X_29>=REF(X_29,1) AND MA(CLOSE,3)>=REF(MA(CLOSE,3),1) OR (X_29>=REF(X_29,1) AND X_37>0 AND MA(CLOSE,3)>=REF(MA(CLOSE,3),1)) OR (X_21>=X_23 AND X_37>0 AND MA(CLOSE,3)>=REF(MA(CLOSE,3),1)) OR (X_21>=X_23 AND X_37>0 AND X_29>=REF(X_29,1)),50,DRAWNULL),NODRAW,COLORLIBLUE,LINETHICK3;
红色买进:IF(X_21>=X_23 AND X_29>=REF(X_29,1) AND X_37>0 AND MA(CLOSE,3)>=REF(MA(CLOSE,3),1),50,DRAWNULL),NODRAW,COLORRED,LINETHICK3;
X_39:=40;
STICKLINE(X_39,(-0.5),(-7),4.2,0),COLORLIBLUE;
STICKLINE(蓝色卖出,(-0.5),(-7),4.2,0),COLORBLUE;
STICKLINE(减仓,(-0.5),(-7),4.2,0),COLORLIBLUE;
STICKLINE(红色买进,(-0.5),(-7),4.2,0),COLORRED;
X_40:=EMA(X_21,3);
X_41:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_42:=EMA(X_41,9);
X_43:=BArslAST(REF(crOSS(X_41,X_42),1));
X_44:=REF(CLOSE,X_43+1)>CLOSE AND REF(X_41,X_43+1)<X_41 AND CROSS(X_41,X_42);
X_45:=BARSLAST(REF(CROSS(X_42,X_41),1));
X_46:=REF(CLOSE,X_45+1)<CLOSE AND REF(X_41,X_45+1)>X_41 AND CROSS(X_42,X_41);
macd底背:IF(X_44>0,(-0.1),0),NODRAW,COLORMAGENTA;
MacD顶背:IF(X_46>0,0.1,0),NODRAW,COLORGREEN;
STICKLINE(X_44>0,107,100,3,0),COLORMAGENTA;
STICKLINE(X_46>0,107,100,3,0),COLORGREEN;

关键词:
免责声明:本站内容部分来源于网络;如有侵权请告知删除;