通达信一进二选股指标公式

时间:2024-02-10 12:05:10    阅读:256
 一字涨停:=(O>=REF(C,1)*1.099);去除ST:=EXIST(C/REF(C,1)>1.055,60);去除停牌:=DYNAINFO(4)>0;减负:=一字涨停 AND 去除ST AND 去除停牌;再减:=(NOT(减负)||CODELIKE('688'));N:=2;ZT:=C>=ZTPRICE(REF(C,1),0.1);首板N:=(COUNT(ZT,N)=1 AND ZT);M1:=V/700000000;M2:=1.1*(MAX(H,REF(C,1))/MIN(L,REF(C,1))-1);M3:=2.5*MAX(M1,M2);M4:=DMA(C,M3);M5:=SMA(20*(M4/REF(M4,1)-1),2,1);M6:=EMA(M5,2);M7:=0.24;M8:=C>=REF(C,1);XX:= IF(M5>M7 AND M6>=0.005 AND M8,1,0);XXX:=crOSS(XX,0.5) AND COUNT(XX>0.5,10)=1;QB:="kdj.J"-REF("kdJ.J",1)>30 AND C/REF(C,1)>1.043 AND "macd.MACD">0 AND "MACD.DEA">0;LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));LQ:=FILTER(LS,28)*100 AND L>REF(C,1)*0.93;XG:=QB OR LQ AND XXX;M11:=9;M12:=10;B1:=C/REF(C,1)>1+0.01*M11;B2:=EXIST(C/REF(C,1)>1+0.01*M11,M12);B3:=C/REF(C,1)>1+0.01*M11;MM:=IF(B1+B2+B3=3,1,0);CC:=(H-C)/(C-O)<0.33;DD:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND (O-L)/(C-O)>=1.48 AND L<REF(L,1) AND L<REF(L,2);EE:=(C/REF(C,1)-1)>=0.08;AA:=V>REF(V,1)*1.9 AND C>REF(C,1) AND C/REF(C,1)-1>=0.049 AND CC;BB:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND V>REF(V,1) AND V>REF(V,1)*2.5 AND CC;CCB:=EMA(2.055*EMA(EMA(H,34),34)-EMA(EMA(L,34),34),5),COLORCYAN,LINETHICK2;YDXG:=IF(FILTER(AA OR BB OR DD OR EE AND CCB>C,34),1,0) AND MM;LYQD:=XG OR YDXG;P:=CROSS(LYQD,1),LYQD-LYQD*0.14 AND 首板N;QUI:=H=C;A:=(C-REF(C,1))/REF(C,1)*100>=0.93 AND QUI;T:=BARSLAST(P);一进二9055:=T AND A AND T<=1 AND C/REF(C,1)>1.02 AND 再减;X_1:=BARSCOUNT(CLOSE);X_2:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH;X_3:=EVERY(X_2,X_1) OR X_1=1;X_4:=NOT(X_3 OR NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) OR INBLOCK(4));X_5:=2;X_6:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1);X_7:=COUNT(X_6,X_5)=1 AND X_6;X_8:=vol/700000000;X_9:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);X_10:=2.5*MAX(X_8,X_9);X_11:=DMA(CLOSE,X_10);X_12:=SMA(20*(X_11/REF(X_11,1)-1),2,1);X_13:=EMA(X_12,2);X_14:=0.24;X_15:=CLOSE>=REF(CLOSE,1);X_16:=IF(X_12>X_14 AND X_13>=0.005 AND X_15,1,0);X_17:=CROSS(X_16,0.5) AND COUNT(X_16>0.5,10)=1;X_18:=KDJ.J-REF(KDJ.J,1)>30 AND CLOSE/REF(CLOSE,1)>1.043 AND MACD.MACD>0 AND MACD.DEA>0;X_19:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));X_20:=FILTER(X_19,28)*100 AND LOW>REF(CLOSE,1)*0.93;X_21:=X_18 OR X_20 AND X_17;X_22:=9;X_23:=10;X_24:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;X_25:=EXIST(CLOSE/REF(CLOSE,1)>1+0.01*X_22,X_23);X_26:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;X_27:=IF(X_24+X_25+X_26=3,1,0);X_28:=(HIGH-CLOSE)/(CLOSE-OPEN)<0.33;X_29:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND (OPEN-LOW)/(CLOSE-OPEN)>=1.48 AND LOW<REF(LOW,1) AND LOW<REF(LOW,2);X_30:=CLOSE/REF(CLOSE,1)-1>=0.08;X_31:=VOL>REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)-1>=0.049 AND X_28;X_32:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1) AND VOL>REF(VOL,1)*2.5 AND X_28;X_33:=EMA(2.055*EMA(EMA(HIGH,34),34)-EMA(EMA(LOW,34),34),5);X_34:=IF(FILTER(X_31 OR X_32 OR X_29 OR X_30 AND X_33>CLOSE,34),1,0) AND X_27;X_35:=X_21 OR X_34;X_36:=X_35-X_35*0.14 AND X_7;X_37:=HIGH=CLOSE;X_38:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=0.93 AND X_37;X_39:=BARSLAST(X_36);神器9108:=X_39 AND X_38 AND X_39<=1 AND CLOSE/REF(CLOSE,1)>1.02 AND X_4 AND 再减;大全1:一进二9055 OR 神器9108;

关键词: