通达信涨停量化指标公式

时间:2024-02-10 12:06:10    阅读:250
 峰谷周期:=5;峰谷虚实:=1;高量周期:=10;M周期内:=10;X3:=REF(CLOSE,1);X4:=ISLASTBAR AND CLOSE<500;X5:=vol;X6:=MA(VOL,5);X7:=X5<=LLV(X5,100)*1;X8:=COUNT(X7,5)>=3 OR X6<=LLV(X6,100) AND X5>0 AND BARSCOUNT(X5)>=100;X9:=FILTER(X8,5);X10:=VOL>=REF(VOL,1)*1.9 AND CLOSE>X3;X11:=HIGH<0.382*HHV(HIGH,240) OR LOW<1.382*LLV(LOW,240);X12:=VOL<0.382*HHV(VOL,240) AND MA(VOL,5)<=MA(VOL,40);X13:=X12 AND X11;X14:=VOL/REF(VOL,1)>=1.1;X15:=CLOSE>OPEN AND BETWEEN(VOL/REF(VOL,1),1.1,2.5);X16:=CLOSE>REF(CLOSE,1) AND REFX(LLV(MIN(CLOSE,OPEN),3),3)>=LOW;X17:=X14 AND X16;X18:=X17 AND X13;X19:=CLOSE>OPEN AND CLOSE<REFX(OPEN,1) AND REFX(X16,1);X20:=LLV(MIN(OPEN,CLOSE),3);X21:=0.97*MA(VOL,3)<=REF(VOL,3);X22:=REF(CLOSE>X3 AND VOL>1.1*REF(VOL,1),3) AND CLOSE>=REF(CLOSE,3) AND REF(CLOSE>=OPEN,3) AND X20>=REF(OPEN,3) AND X21;X23:=BARSLAST(X22);X24:=REF(X20,X23);X25:=REF(CLOSE,X23+3);X26:=REF(OPEN,X23+3);X27:=峰谷周期;X28:=IF(峰谷虚实=0,HIGH,MAX(CLOSE,OPEN));X29:=5;X30:=X29*1;X31:=BARSLAST(FILTER(BACKSET(FILTER(REF(X28,X30)=HHV(X28,2*X30+1),X30),X30+1),X30));X32:=REF(X28,X31);X33:=X29*2;X34:=BARSLAST(FILTER(BACKSET(FILTER(REF(X28,X33)=HHV(X28,2*X33+1),X33),X33+1),X33));X35:=REF(X28,X34);X36:=X29*4;X37:=BARSLAST(FILTER(BACKSET(FILTER(REF(X28,X36)=HHV(X28,2*X36+1),X36),X36+1),X36));X38:=REF(X28,X37);X39:=X29*8;X40:=BARSLAST(FILTER(BACKSET(FILTER(REF(X28,X39)=HHV(X28,2*X39+1),X39),X39+1),X39));X41:=REF(X28,X40);X42:=1+0/100;X43:=crOSS(CLOSE,X42*X32);X44:=X43 AND REF(HHV(X28,X31),1)<=X32;X45:=CROSS(CLOSE,X42*X35);X46:=X45 AND REF(HHV(X28,X34),1)<=X35;X47:=CROSS(CLOSE,X42*X38);X48:=X47 AND REF(HHV(X28,X37),1)<=X38;X49:=CROSS(CLOSE,X42*X41);X50:=X49 AND REF(HHV(X28,X40),1)<=X41;X51:=X44 OR X48 OR X48 OR X50;X52:=IF(X44,X31,IF(X46,X34,IF(X48,X37,X40)));X53:=REF(X28,X52);X54:=IF(峰谷虚实=0,LOW,MIN(CLOSE,OPEN));X55:=FILTER(BACKSET(FILTER(REF(X54,X27)=LLV(X54,2*X27+1),X27),X27+1),X27);X56:=BARSLAST(X55);X57:=REF(X54,X56);X58:=0.002*LOW+0.005;X59:=X55 AND Abs(X57-REF(X57,1))<=X58 AND REF(X56,1)>=5;X60:=X55 AND ABS(X57-REF(X53,X52+1))<=X58;X61:=BETWEEN(X28,X53*0.995,X53*1.001);X62:=COUNT(X61,10)>=3 AND HHV(HIGH,X52)<=X53*1.001;X63:=X5/HHV(X5,20)<=0.618;X64:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)<=0.96 OR CLOSE/OPEN<=0.96) AND X63;X65:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)>=1.04 OR CLOSE/OPEN>=1.04) AND X63;X66:=3;X67:=3;X68:=HHV(HIGH,240)-LLV(LOW,240);X69:=IF(X68<=1,0,IF(X68<=5,0.02,2.5/1000*X68)+0.005);X70:=VOL>=REF(VOL,1)*1.1 OR CLOSE>OPEN*IF(CLOSE<500,1.03,1.01);X71:=REFX(LLV(LOW,X67),X67);X72:=X70 AND LOW<=X71;X73:=REF(HHV(HIGH,X66),1);X74:=REF(HHV(MAX(CLOSE,OPEN),X66),1);X75:=X72 AND ABS(X73-X71)<=X69;X76:=X72 AND ABS(X74-X71)<=X69;X77:=REFX(LLV(MIN(CLOSE,OPEN),X67),X67);X78:=X70 AND LOW<=X77;X79:=X78 AND ABS(X73-X77)<=X69;X80:=X78 AND ABS(X74-X77)<=X69;X81:=X75 OR X76 OR X79 OR X80;X82:=50/IF(CLOSE>=1,10000,100000);X83:=1.1*X3-X82;X84:=1.05*X3-X82;X85:=0.9*X3+X82;X86:=0.95*X3+X82;X87:=NAMELIKE(4) OR NAMELIKE(5);X88:=IF(X87,CLOSE>=X84,CLOSE>=X83);X89:=CLOSE<OPEN AND (CLOSE<=X86 OR CLOSE<0.95*OPEN+X82) OR (CLOSE>1000 AND CLOSE<=X3*0.975);X90:=X89;X91:=BARSLAST(FILTER(X90,3));X92:=REF(OPEN,X91);X93:=LOW<OPEN*0.96 AND X11 AND MA(CLOSE,60)<=REF(MA(CLOSE,60),1);X94:=BARSLAST(X93);X95:=REF(OPEN,X94)>=HHV(MAX(CLOSE,OPEN),X94) AND REF(LOW,X94)<=1.01*LLV(MIN(CLOSE,OPEN),X94);X96:=X95 AND X94>=5 AND MA(VOL,5)<MA(VOL,60);X97:=FILTER(X96,5);X98:=LOW*0.005;X99:=LOW<=LLV(LOW,3);X100:=ABS(LOW-REF(X24,1))<=X98 OR ABS(LOW-REF(X24,X23+1))<=X98 AND LOW<=LLV(MIN(OPEN,CLOSE),X23);X101:=ABS(LOW-REF(X25,1))<=X98 OR ABS(LOW-REF(X25,X23+1+3))<=X98;X102:=ABS(LOW-REF(X26,1))<=X98 OR ABS(LOW-REF(X26,X23+1+3))<=X98;X103:=ABS(LOW-REF(X53,1))<=X98 OR ABS(LOW-REF(X53,X52+1))<=X98;X104:=ABS(LOW-REF(X57,1))<=X98 OR ABS(LOW-REF(X57,X56+1))<=X98;X105:=ABS(LOW-REF(X92,1))<=X98 AND X91>=1;X106:=X99 AND (X100 OR X103 OR X104 OR X105 OR X101 OR X102);X107:=(MIN(OPEN,CLOSE)-LOW)/CLOSE>=0.02 AND (MIN(OPEN,CLOSE)-LOW)/(HIGH-LOW)>0.5>=0.02;X108:=LOW>REF(HIGH,1);X109:=REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND X107 AND HIGH<REF(HIGH,1) AND VOL<REF(VOL,1)*1;X110:=CLOSE>OPEN AND CLOSE<REF(CLOSE,1);X111:=CLOSE<OPEN AND CLOSE>REF(CLOSE,1);X112:=AMOUNT/VOL/100;X113:=CLOSE<OPEN AND X112>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,1) AND X112<=HIGH;X114:=X111 OR X113;X115:=CLOSE>OPEN AND CLOSE>X3 AND VOL<REF(VOL,1);X116:=REF(VOL,1)>=VOL*1.9 AND REF(CLOSE>REF(CLOSE,1),1);X117:=COUNT(X10,3)=1 AND X116;X118:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;X119:=SUM(X118,3)<=(-5);X120:=CLOSE>OPEN AND CLOSE>REF((OPEN+CLOSE)/2,1);X121:=REF(X119,1) AND X120;X122:=(CLOSE-OPEN)/OPEN*100>=3;X123:=BETWEEN(MIN(CLOSE,OPEN),REF(OPEN+(CLOSE-OPEN)*0.6,1),REF(CLOSE,1)) AND CLOSE<X3;X124:=VOL/REF(VOL,1)<=0.71;X125:=REF(X122,1) AND X123 AND X124;X126:=COUNT(CLOSE>=X3,3)=3 AND REF(COUNT(VOL>=REF(VOL,1),2)=2,1);X127:=MIN(CLOSE,OPEN)>REF(MAX(CLOSE,OPEN),1);X128:=COUNT(X127,3)=3;X129:=HIGH=LOW;X130:=COUNT(X129,3)=3=0 AND X129=0;X131:=X128 AND X130;X132:=4;X133:=IF(峰谷虚实=1,MIN(CLOSE,OPEN),LOW);X134:=BARSLAST(X10);X135:=LLV(X133,X134)>=REF(X133,X134) AND X134>=X132;X136:=FILTER(BACKSET(FILTER(REF(VOL,X27)=HHV(VOL,2*X27+1),X27),X27+1),X27);X137:=BARSLAST(X136);X138:=LLV(X133,X137)>=REF(X133,X137) AND X137>=X132 AND X137>=高量周期;X139:=LOW>REF(HIGH,1);X140:=BARSLAST(X10);X141:=LLV(LOW,X140)>REF(HIGH,X140+1) AND X140>=X132;X142:=X135 OR X138 OR X141;X143:=MIN(CLOSE,OPEN);X144:=MAX(CLOSE,OPEN);X145:=HIGH-LOW;X146:=CLOSE>=1.0497*REF(CLOSE,1)-X82;X147:=RANGE(ABS(CLOSE-OPEN)/X145,0,0.8) AND (HIGH-X144)/X145>=0.1 AND (X143-LOW)/X145>=0.1;X148:=LLV(X143,2)>=REF(0.5*(X144+X143),2);X149:=HHV(VOL,2)<REF(VOL,2);X150:=REF(X146,2) AND COUNT(X147,2)=2 AND X148 AND X149;X151:=LLV(X143,3);X152:=(CLOSE-OPEN)/OPEN>=5/100 OR X118>=5;X153:=20;X154:=(X143-LLV(X143,4))/LLV(X143,4)<3/100;X155:=LLV(X143,5)=LLV(X143,X153) AND BARSCOUNT(CLOSE)>=X153;X156:=0;X157:=IF(X156=1,CLOSE>=OPEN AND REF(X152=0 OR CLOSE<OPEN,1) AND CLOSE>REF(X144,1),1);X158:=X152 OR (BETWEEN(X118,3,5) AND X10) AND X157 AND X154;X159:=BARSLAST(X158>0);X160:=REF(X159,1)+1;X161:=LLV(MIN(CLOSE,OPEN),X160);X162:=X161>=REF(LOW,X160);X163:=COUNT(X158>0,13)=2;X164:=REF(OPEN,X160);X165:=ABS(OPEN-X164)/X164<10/100;X166:=1*(X158 AND X163 AND X165 AND REF(X162,1) AND BETWEEN(X160,4,13));地量:=COUNT(X9,M周期内);DRAWTEXT(ISLASTBAR,3,'--地量'),COLORBROWN;STICKLINE(地量,0,5,3,0),COLORBROWN;矮将:=COUNT(X18,M周期内);DRAWTEXT(ISLASTBAR,8,'--矮将');STICKLINE(矮将,5,10,3,0);金柱:=COUNT(REFX(X22,3),M周期内);DRAWTEXT(ISLASTBAR,13,'--金柱'),COLORF020A0;STICKLINE(金柱,10,15,3,0),COLORF020A0;元帅:=COUNT(X19,M周期内),COLORRED;DRAWTEXT(ISLASTBAR,18,'--元帅'),COLORFF66E0;STICKLINE(元帅,15,20,3,0),COLORFF66E0;涨板:=COUNT(X88,M周期内);DRAWTEXT(ISLASTBAR,23,'--涨板'),COLOR00CDCD;STICKLINE(涨板,20,25,3,0),COLOR00CDCD;零号:=COUNT(X108,M周期内);DRAWTEXT(ISLASTBAR,28,'--零号'),COLOR7610CD;STICKLINE(零号,25,30,3,0),COLOR7610CD;过左:=COUNT(X51,M周期内);DRAWTEXT(ISLASTBAR,33,'--过左'),COLORAAE8EE;STICKLINE(过左,30,35,3,0),COLORAAE8EE;阴短:=COUNT(X64,M周期内),COLORLIGREEN;DRAWTEXT(ISLASTBAR,37,'--阴短'),COLORLIGREEN;STICKLINE(阴短,35,40,3,0),COLORLIGREEN;阳矮:=COUNT(X65 AND CLOSE>LOW,M周期内),COLORLIRED;DRAWTEXT(ISLASTBAR,43,'--阳矮'),COLORLIRED;STICKLINE(阳矮,40,45,3,0),COLORLIRED;踩精:=COUNT(X106,M周期内),COLORCYAN;DRAWTEXT(ISLASTBAR,48,'--踩精'),COLORCYAN;STICKLINE(踩精,45,50,3,0),COLORCYAN;假阴:=COUNT(X114,M周期内);DRAWTEXT(ISLASTBAR,53,'--假阴'),COLORCD329A;STICKLINE(假阴,50,55,3,0),COLORCD329A;背反:=COUNT(X115,M周期内);DRAWTEXT(ISLASTBAR,58,'--背反'),COLOR8B668B;STICKLINE(背反,55,60,3,0),COLOR8B668B;伸缩:=COUNT(X117,M周期内);DRAWTEXT(ISLASTBAR,63,'--伸缩'),COLORCC3299;STICKLINE(伸缩,60,65,3,0),COLORCC3299;次阳:=COUNT(X121,M周期内),COLORRED;DRAWTEXT(ISLASTBAR,68,'--次阳'),COLORRED;STICKLINE(次阳,65,70,3,0),COLORRED;悬阴:=COUNT(X125,M周期内);DRAWTEXT(ISLASTBAR,73,'--悬阴'), COLORAAC1C5;STICKLINE(悬阴,70,75,3,0), COLORAAC1C5;三元:=COUNT(X131,M周期内);DRAWTEXT(ISLASTBAR,78,'--三元'),COLOR00008B;STICKLINE(三元,75,80,3,0),COLOR00008B;梯四:=COUNT(X126,M周期内);DRAWTEXT(ISLASTBAR,83,'--梯四'),COLORD5EFFF;STICKLINE(梯四,80,85,3,0),COLORD5EFFF;三绝:=COUNT(X142,M周期内)>=1;DRAWTEXT(ISLASTBAR,88,'--三绝'),COLORF020A0;STICKLINE(三绝,85,90,3,0),COLORF020A0;双休:=COUNT(X150,M周期内),COLOR1A1A8B;DRAWTEXT(ISLASTBAR,93,'--双休'),COLOR1A1A8B;STICKLINE(双休,90,95,3,0),COLOR1A1A8B;双阳:=COUNT(X166,M周期内);DRAWTEXT(ISLASTBAR,98,'--双阳'),COLOR69698B;STICKLINE(双阳,95,100,3,0),COLOR69698B;双剑:=COUNT(X109,M周期内);DRAWTEXT(ISLASTBAR,103,'--双剑'),COLOR78888B;STICKLINE(双剑,100,105,3,0),COLOR78888B;十字:=COUNT(X81,M周期内);DRAWTEXT(ISLASTBAR,108,'--十字'),COLOR42578B ;STICKLINE(十字,105,110,3,0),COLOR42578B ;直憋:=COUNT(X97,M周期内);DRAWTEXT(ISLASTBAR,113,'--直憋'),COLOR525252;STICKLINE(直憋,110,115,3,0),COLOR525252;峰谷:COUNT(X59 OR X60,M周期内),NODRAW;咬峰:COUNT(X62,M周期内),NODRAW;X167:=IF(涨板>0,1,0)+IF(地量>0,1,0)+IF(矮将>0,1,0)+IF(金柱>0,1,0)+IF(元帅>0,1,0);X168:=IF(过左>0,1,0)+IF(伸缩>0,1,0)+IF(阴短>0,1,0)+IF(阳矮>0,1,0)+IF(直憋>0,1,0);X169:=IF(踩精>0,1,0)+IF(双剑>0,1,0)+IF(假阴>0,1,0)+IF(背反>0,1,0)+IF(零号>0,1,0);X170:=IF(十字>0,1,0)+IF(峰谷>0,1,0)+IF(次阳>0,1,0)+IF(三元>0,1,0)+IF(悬阴>0,1,0);X171:=IF(梯四>0,1,0)+IF(咬峰>0,1,0)+IF(三绝>0,1,0)+IF(双休>0,1,0)+IF(双阳>0,1,0);总类:X167+X168+X169+X170+X171,NODRAW,COLORRED;X172:=涨板+地量+矮将+金柱+元帅;X173:=过左+伸缩+阴短+阳矮+直憋;X174:=踩精+双剑+假阴+背反+零号;X175:=十字+峰谷+次阳+三元+悬阴;X176:=梯四+咬峰+三绝+双休+双阳;总数:X172+X173+X174+X175+X176,NODRAW,COLORYELLOW;NOTEXTK0:0;NOTEXTK1:5;NOTEXTK2:10;NOTEXTK3:15;NOTEXTK4:20;NOTEXTK5:25;NOTEXTK6:30;NOTEXTK7:35;NOTEXTK8:40;NOTEXTK9:45;NOTEXTK10:50;NOTEXTK11:55;NOTEXTK12:60,;NOTEXTK13:65,;NOTEXTK14:70;NOTEXTK15:75;NOTEXTK16:80;NOTEXTK17:85;NOTEXTK18:90;NOTEXTK19:95;NOTEXTK20:100;NOTEXTK21:105;NOTEXTK22:110;NOTEXTK23:115;

关键词: