通达信浪子缠主图指标公式

时间:2024-02-10 12:08:10    阅读:257
 DRAWGBK(C>0,RGB(150,100,0),RGB(50,100,0),0,'',0);{盖世英雄}AA:=EMA(INDEXC,300)/EMA(C,300);XC:=(INDEXC/AA);大盘:EMA(XC,10),COLORWHITE;BB:=(H+L+2*C)/4,COLORBLUE;DRAWBAND(大盘,RGB(50,150,0),LLV(L,600),RGB(250,200,0));{牛线}A:=(20 * H) + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9));B:=10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20);AAAR5:=(A+ B) / 210;DRAWBAND(IF(((EMA(AAAR5,90)) - ((((C - (EMA(AAAR5,90))) * C) - (EMA(AAAR5,90))) / (EMA(AAAR5,90))))>(EMA(AAAR5,90)),((EMA(AAAR5,90)) - ((((C - (EMA(AAAR5,90))) * C) - (EMA(AAAR5,90))) / (EMA(AAAR5,90)))),(EMA(AAAR5,90))),RGB(0,0,0),(EMA(AAAR5,90)),RGB(250,200,0));龙线:MA(C,240),COLOR00FF00,LINETHICK2;牛线:EMA(AAAR5,90),LINETHICK1,COLORYELLOW;相对:=(牛线-(((C-牛线)*C)-牛线)/牛线),COLORYELLOW;缠牛线:IF(相对>牛线,相对,牛线),COLOR00AAAA;重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382,COLORRED,LINETHICK1;GAO:=HHV(C,60)-LLV(C,60);rsi:=SMA(MAX(重心-REF(重心,1),0),5,1)/SMA(Abs(重心-REF(重心,1)),5,1);准线:EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55),COLORFFAA00,LINETHICK1;缠准:=重心+GAO*(RSI-0.5),COLOR999900,LINETHICK1;缠准线:IF(准线>REF(准线,1) AND C>牛线,缠准,准线),COLOR999900;EMA(AAAR5,90),LINETHICK2,COLORYELLOW;DRAWKLINE(HIGH,OPEN,LOW,CLOSE);{彩K}XG1:=C/REF(C,1)>1.0618;STICKLINE(XG1,L,H,0,1),COLOR0088EE;STICKLINE(XG1,CLOSE,OPEN,3,0),COLOR0055AA;STICKLINE(XG1,CLOSE,OPEN,2.8,0),COLOR0066BB;STICKLINE(XG1,CLOSE,OPEN,2.5,0),COLOR0077CC;STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLOR0088DD;STICKLINE(XG1,CLOSE,OPEN,1.7,0),COLOR0099EE;STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLOR00AAFF;STICKLINE(XG1,CLOSE,OPEN,0.7,0),COLOR00CCFF;STICKLINE(XG1,CLOSE,OPEN,0.2,0),COLOR00FFFF;涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>=O;STICKLINE(涨停,H,L,0,1),COLORRED;IF(准线>=REF(准线,1) AND C>牛线,缠准,准线),COLOR999900;IF(准线< REF(准线,1),准线,DRAWNULL),COLORFFAA00,LINETHICK2;IF(准线>=REF(准线,1),准线,DRAWNULL),COLOR0000FF,LINETHICK2;{周kdj}RSV周:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45));K周:=SMA(RSV周,15,1),COLORFF00FF,LINETHICK1;D周:=SMA(K周,15,1),COLORWHITE,LINETHICK3;J周:=3*K周-2*D周;DRAWICON(crOSS(C,缠牛线) AND (牛线>龙线 OR (C>龙线 AND C>牛线)),牛线*1.05,14);DRAWICON(CROSS(C,大盘) AND C>缠牛线,牛线,31);{走强};{所属板块、概念}DRAWTEXT_FIX(1,0.005,0,0,'所属风格:'),COLORRED;DRAWTEXT_FIX(1,0.06,0,0,FGBLOCK),COLORRED;DRAWTEXT_FIX(1,0.005,0.06,0,'所属概念:'),COLORMAGENTA;DRAWTEXT_FIX(1,0.06,0.06,0,GNBLOCK),COLORMAGENTA;DRAWTEXT_FIX(1,0.005,0.12,0,'所属板块:'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.12,0,DYBLOCK),COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.12,0,HYBLOCK),COLORYELLOW;{流通盘}DRAWTEXT_FIX(1,0.42,0.05,0,'流通股'),COLORYELLOW;DRAWNUMBER_FIX(1,0.47,0.05,0,CONST(FINANCE(7)/100000000)),COLORYELLOW;DRAWTEXT_FIX(1,0.42,0.0,0,STRCAT(STRCAT('流通盘:',CON2STR((FINANCE(46)*C/100000000),2)),'亿')),COLORYELLOW;YSTB:=STRCAT(CON2STR(FINANCE(44)/1,2),'%');LRTB:=STRCAT(CON2STR(FINANCE(43)/1,2),'%');DRAWTEXT_FIX(1,0.6,0,0,'营收同比:'),COLORWHITE;DRAWTEXT_FIX(1,0.66,0,0,YSTB),COLORWHITE;DRAWTEXT_FIX(1,0.74,0,0,'利润同比:'),COLORWHITE;DRAWTEXT_FIX(1,0.8,0,0,LRTB),COLORWHITE;净资收益率:=(FINANCE(33)/FINANCE(34)*100);主营利润率:=(FINANCE(23)/FINANCE(20)*100);主营业增长率:=FINANCE(44);每股净资产:=CONST(FINANCE(34));每股收益:=CONST(FINANCE(38));净利润增长率:=FINANCE(43);市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));现金负债比:=(FINANCE(25)/FINANCE(15));每股未分配:=CONST(FINANCE(32));每股公积金:=CONST(FINANCE(18));SY01:=净资收益率>3;SY02:=净资收益率>0.01 AND 净资收益率<=3;SY03:=主营利润率>2;SY04:=主营利润率>0;SY05:=主营业增长率>1;SY06:=主营业增长率>0;SY07:=净利润增长率>2;SY08:=净利润增长率>0.2;SY09:=每股收益>0.01;SY10:= 每股收益>0.001;SY11:=每股净资产>2;SY12:=每股净资产>0.01;SY13:=每股未分配>0.5;SY14:=每股未分配>0.001;SY15:=每股公积金>0.5;SY16:=每股公积金>0.002;SY17:=每股未分配>=2 AND 每股公积金>=2;SY18:=每股未分配< 2 OR 每股公积金< 2;:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11 AND SY13 AND SY15;较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12 AND SY14 AND SY16;一般:=NOT() AND NOT(较好);DRAWTEXT_FIX( AND 较好=0,0.6,0.05,0,'综合评估基本面:!'),COLORMAGENTA;DRAWTEXT_FIX(较好,0.6,0.05,0,'综合评估基本面:较好!'),COLORRED;DRAWTEXT_FIX(一般,0.6,0.05,0,'综合评估基本面:一般!'),COLORGREEN;DRAWTEXT_FIX(SY17,0.74,0.05,0,'是否具备高送转潜力:是!'),COLORMAGENTA;DRAWTEXT_FIX(SY18,0.74,0.05,0,'是否具备高送转潜力:否!'),COLORGREEN;{DRAWTEXT_FIX(1,0,5,0,'~☆~ 买入不下准线涨个不停个股=买点在60kd金叉且缠准线V型反转时 ~☆~'),COLORRED;};

关键词: