通达信新组合建仓指标公式

时间:2024-02-10 12:09:10    阅读:320
 DRAWGBK(C>0,RGB(0,0,110),RGB(0,25,0),0,' ',0);DLYZ1:=SUM((WINNER(C)*100),30)/30*0.1;DLYZ2:=SUM((WINNER(C)*100),20)/20*0.4;DLYZ3:=SUM((WINNER(C)*100),10)/10*0.3;DLYZ4:=SUM((WINNER(C)*100),5)/5*0.1;DLYZ5:=SUM((WINNER(C)*100),3)/3*0.1;DLYZZ:=DLYZ1+DLYZ2+DLYZ3+DLYZ4+DLYZ5;换手:=vol/CAPITAL*100<10;赚钱效应:IF(DLYZZ>38,DLYZZ,DLYZZ*1.3),NODRAW;活跃度:IF(SUMBARS(VOL,CAPITAL)<100,100-SUMBARS(VOL,CAPITAL),1),NODRAW;{六--彩神龙}M:=13;N:=30;A01:=(C+O+L+H)/4;A02:=(WINNER((A01 * 1.04)) * 100.000);A03:=(WINNER((A01 * 0.96)) * 100.000);A04:=A03,NODRAW;A08:=A02-A03,NODRAW;A06:=( 100.000 - A02),NODRAW;STICKLINE( 1.000,-100+A04,-100,2,0),COLORRED;STICKLINE( 1.000,-100+A02,0,2,0),COLORGREEN;STICKLINE( 1.000,-100+A04,(0-A06), 2,0),COLORYELLOW;量化1:=100-100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));量化2:=100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));A:=MA(量化2,13);{DRAWBAND(量化1,255,60,0);}资金:=量化1-A,COLORYELLOW;日:=1321212;:=IF(DATE<日,1,DRAWNULL);DY11:=(2*CLOSE+HIGH+LOW)/4*;DY22:=LLV(LOW,34)*;DY33:=HHV(HIGH,34)*;A11:=EMA((DY11-DY22)/(DY33-DY22)*100,9)*;B11:=EMA(0.667*REF(A11,1)+0.333*A11,2)*;AA1:=EMA(CLOSE,7)-EMA(CLOSE,21);RR:=EMA(AA1,2)*1,COLORSTICK;{多空背景墙}Q_1:=C-REF(C,1); Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(Abs(Q_1),6),6);Q_3:=crOSS(EMA(C,19),EMA(C,7));Q_4:=CROSS(EMA(C,7),EMA(C,19));Z1:=L=LLV(L,BARSLAST(Q_3)+1);Z2:=LLV(L,BARSLAST(Q_3)+1);Z3:=H=HHV(H,BARSLAST(Q_4)+1);Z4:=HHV(H,BARSLAST(Q_4)+1);Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0),COLORMAGENTA,LINETHICK2;Y1:=H=HHV(H,BARSLAST(Q_4)+1);Y2:=HHV(H,BARSLAST(Q_4)+1);Y3:=L=LLV(L,BARSLAST(Q_3)+1);Y4:=LLV(L,BARSLAST(Q_3)+1);Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0),COLORCYAN,LINETHICK2;X01:=LLV(Q_2,2)=LLV(Q_2,7);X2:=COUNT(Q_2<0,2);X3:=CROSS(Q_2,MA(Q_2,2));X4:=REF(Q_B,1)<REF(Q_B,2);X5:=Q_A>REF(Q_B,1);持股:IF(Q_B<REF(Q_B,1) AND Q_B<Q_A,60,0),STICK,COLORLIRED,LINETHICK9;STICKLINE(Q_B<REF(Q_B,1),60,0,4,0)COLORLIBLUE;{伏击游资}{STICKLINE(C>0,100,130,5,0),COLOR64320A;HHHH:=HHV(H,250);LLLL:=LLV(L,250);主力:=(REF(HHHH,1)/REF(LLLL,1))*100,COLORLIMAGENTA;游资:=REF(C,1)/REF(LLV(L,250),1)*100,COLORYELLOW;伏击:=游资>=主力,COLORRED,NODRAW;STICKLINE(伏击>0,100,130,1,0),COLORRED;}{买进强}{ABC0:=(2*O+H+L+3*C)/7;ABC1:=CAPITAL*ABC0;ABC2:=SMA(AMOUNT,10,1)/100000;ABC3:=MA(C*3,5);ABC4:=ABC2*C*3/ABC3*1/10;ABC5:=ABC2*O*3/ABC3*1/10;ABC6:=ABC2*H*3/ABC3*1/10;ABC7:=ABC2*L*3/ABC3*1/10;ABC8:=(2*ABC5+ABC6+ABC7+3*ABC4)/7;ABC9:=DMA(EMA(ABC4,2),SUM(V,1)*ABC8);ABC10:=EMA(ABC9,2);ABCA:=ABC9>ABC10;ABCB:=EMA(ABC1-ABC9,1);ABCC:=REF(ABCB,1);ABCD:=ABCB>ABCC;ABCS:=ABCD AND C>O;ABCF:=(ABC9-ABC10)*1.5;ABCT:=IF(ABCA AND ABCS,ABCF/10000,0);买进强烈:=ABCT,POINTDOT,COLOR10E6FF;STICKLINE(ABCA AND ABCS,80,80+ABCF,2,0),COLOR10E6FF;}主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)*,COLORYELLOW,LINETHICK1;STICKLINE( 主力持仓 AND 主力持仓>60,60,主力持仓 ,1.5,0 ),COLORRED;GUA1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);GUA2:=SMA(ABS(LOW-GUA1),13,1)/SMA(MAX(LOW-GUA1,0),10,1);GUA3:=EMA(GUA2,10);GUA4:=LLV(LOW,33);GUA5:=EMA(IF(LOW<=GUA4,GUA3,0),3)/4;GUA6:=0;主力抄底:=IF(GUA5>REF(GUA5,1),GUA5,0),COLORLIMAGENTA,NODRAW;STICKLINE(GUA5>REF(GUA5,1),0,GUA5,1,0 ),COLORRED;洗盘:=IF(GUA5<REF(GUA5,1),GUA5,0),COLORGREEN,NODRAW;STICKLINE(GUA5<REF(GUA5,1),0,GUA5,1,0),COLORGREEN;GUP1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);GUP2:=SMA(ABS(LOW-GUP1),13,1)/SMA(MAX(LOW-GUP1,0),10,1);GUP3:=EMA(GUP2,10);GUP4:=LLV(LOW,33);GUP5:=EMA(IF(LOW<=GUP4,GUP3,0),3)/3;建仓:=IF(GUP5>REF(GUP5,1),GUP5,0),COLOR00FFFF,NODRAW;STICKLINE(GUP5<REF(GUP5,1),0,GUP5,2,1),COLORGREEN;STICKLINE(GUP5>REF(GUP5,1),0,GUP5,2,1 ),COLORRED;GUP21:=SMA(ABS(HIGH-GUP1),13,1)/SMA(MIN(HIGH-GUP1,0),10,1);GUP31:=EMA(GUP21,10);GUP41:=HHV(HIGH,33);GUP51:=EMA(IF(HIGH>=GUP41,GUP31,0),3)/4,COLORLIBLUE;拉升:=IF(GUP51<REF(GUP51,1),GUP51,0),COLORYELLOW;STICKLINE(GUP51<REF(GUP51,1),0,GUP51/10,1.5,0),COLORYELLOW;出货:=IF(GUP51>REF(GUP51,1),GUP51,0),COLOR33CC33,NODRAW;STICKLINE(GUP51>REF(GUP51,1),0,GUP51/10,1.5,0 ),COLORCYAN;{有庄控盘}P:=0.24;VAR91:=EMA(EMA(CLOSE,9),9);控盘:=(VAR91-REF(VAR91,1))/REF(VAR91,1)*2000;STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;A10:=CROSS(控盘,0);STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;VAR92:=100*WINNER(CLOSE*0.95);STICKLINE(VAR92>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;高度控盘:IF(VAR92>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORLIGREEN;主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLORLIGREEN,NODRAW;无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;{起爆点黄红柱}AVAR2:=REF(LOW,1);AVAR3:=SMA(ABS(LOW-AVAR2),13,1)/SMA(MAX(LOW-AVAR2,0),13,1)*100;AVAR4:=EMA(IF(CLOSE*1.2,AVAR3*13,AVAR3/13),13);AVAR5:=LLV(LOW,34);AVAR6:=HHV(AVAR4,34);AVAR7:=IF(LLV(LOW,56),1,0);AVAR8:=EMA(IF(LOW<=AVAR5,(AVAR4+AVAR6*2)/2,0),3)/618*AVAR7;AA:=AVAR8>REF(AVAR8,1);RR1:=MA(CLOSE,27);RR2:=(CLOSE-RR1)/RR1*100;RRA:=MA(RR2,2);RRB:=BARSLAST(CROSS(-1,RRA)=1);RRD:=RRA<-10 AND RRB>3;建仓区1:STICKLINE(IF(RRD,-12,0),-7,0,3,0),COLORGRAY;{主力抄底}大主力:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1;抄底信号:=10 ;买入个股: IF(CROSS(大主力,抄底信号),15,0),LINETHICK1,COLORWHITE;{火箭}A1111:=FINANCE(42);A211:=DATETODAY(CONST(DATE));A311:=A211-A1111;XDATE:=DAYTODATE(A311)+19000000;上市日期:=STRCAT('上市日期:',CON2STR(XDATE,0));SSTS1:=STRCAT('上市',CON2STR(FINANCE(42),0));SSTS2:=STRCAT(SSTS1,'天');SSTS3:=STRCAT('累计交易:',CON2STR(TOTALBARSCOUNT,0));SSTS4:=STRCAT(SSTS3,'周期');W11:=EMA(C,1);涨停:=W11/REF(W11,1)>=1.095;ZTCS:=COUNT(涨停,BARSSINCE(涨停)+1);NTZZT1:=STRCAT(' 距今',CON2STR(CONST(BARSLAST(涨停)),0));NTZZT2:=STRCAT(NTZZT1,'天有涨停');GZT1:=STRCAT(' 共涨停',CON2STR(ZTCS,0));GZT2:=STRCAT(GZT1,'次');ZTTJ1:=STRCAT(SSTS2,GZT2);ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);龙虎榜潜力:=STRCAT('【涨停统计】',ZTTJ2);AC:=IF(CODELIKE('688'),0,1);JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));ddx:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;V22:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);V5:=SMA(V22*120/FROMOPEN*5,2,1);V010:=SMA(V5,5,1);V20:=SMA(V010,5,1);DY:=CURRBARSCOUNT=1 AND C<REF(C,1);DY2:=REF(V22,1)-DY;TT:=(V22*1.01-REF(V22,1));TT2:=(REF(V22*1.01,1)-REF(V22,2));YY:=TT>3*ABS(TT2);TT1:=EMA(V22,15);A111:=COST(85);A222:=COST(15);A333:=A111-A222;A444:=(A111+A222)/2;筹码:=A333/A444*100<30,LINETHICK0;BU1:=HHV(HIGH,250);BU2:=LLV(LOW,250);BU3:=BU1-BU2;BU4:=(A444-BU2);比例:=A444<(BU3*04+BU2),LINETHICK0;吸筹结束:=筹码 AND 比例;BU5:=C/REF(C,1)>1.04; {AND V/REF(V,1)>2;{ AND H=C;}主力持仓%:=EMA(100*(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30)),3);主力持仓1:=主力持仓%>=75 {AND 主力持仓%<=91} AND C>0 AND CLOSE>OPEN;强庄:=FILTER(主力持仓1 AND 吸筹结束 AND BU4 AND WINNER(C)>=0.90 AND BU5 AND C/REF(C,1)>1.092 AND C=H AND C<40 AND AC,10);X_1:=(2*CLOSE+HIGH+LOW)/4;X_2:=LLV(LOW,5);X_3:=HHV(HIGH,5);X_4:=EMA((X_1-X_2)/(X_3-X_2)*100 ,5);X_5:=MA(X_4,2);X_6:=REF(CLOSE,1)/REF(CLOSE,2)<0.95;X_7:=X_5<20 AND X_6 AND CLOSE>LOW AND OPEN>LOW;X_8:=CLOSE/REF(CLOSE,3)<0.95;X_9:=REF(X_8,1)=1 AND CLOSE/REF(CLOSE,1)>1.025;X_10:=VOL>REF(HHV(VOL,10),1) AND NOT(OPEN=CLOSE) AND HIGH/CLOSE<1.0007;X_11:=REF(EVERY(MA(CLOSE,5)<MA(CLOSE,10),5),1) AND VOL/MA(VOL,10)>1.8;X_12:=COUNT(X_7=1,3)>0 AND REF(CLOSE,1)<REF(CLOSE,2);X_13:=VOL/REF(VOL,1)>1.7 AND REF(OPEN,1)<100;跟庄乾坤:=X_9 AND X_10 AND X_11 AND X_12 AND X_13;DRAWTEXT(跟庄乾坤,10,'跟庄乾坤'),COLORMAGENTA;STICKLINE(跟庄乾坤,14*2.5,12*2.5,3.5,0),COLOR0000FF;STICKLINE(跟庄乾坤,15*2.5,14.9*2.5,1.7,0),COLOR0000FF;STICKLINE(跟庄乾坤,20.11*2.5,9.6*2.5,0.1,0),COLOR0000FF;STICKLINE(跟庄乾坤,19.16*2.5,9.2*2.5,0.3,0),COLOR0000FF;STICKLINE(强庄,14*2.5,12*2.5,3.5,0),COLORA8A8A8;STICKLINE(强庄,15*2.5,14.9*2.5,1.7,0),COLORA8A8A8;STICKLINE(强庄,14.9*2.5,14.8*2,1.9,0),COLORA8A8A8;STICKLINE(强庄,14.8*2,14.7*2.5,2.1,0),COLORA8A8A8;STICKLINE(强庄,14.7*2,14.6*2,2.3,0),COLORA8A8A8;STICKLINE(强庄,14.6*2.5,14.5*2.5,2.5,0),COLORA8A8A8;STICKLINE(强庄,14.5*2.5,14.4*2.5,2.7,0),COLORA8A8A8;STICKLINE(强庄,14.4*2.5,14.3*2.5,2.9,0),COLORA8A8A8;STICKLINE(强庄,14.3*2.5,14.2*2.5,3.1,0),COLORA8A8A8;STICKLINE(强庄,14.2*2.5,14.1*2.5,3.3,0),COLORA8A8A8;STICKLINE(强庄,14.1*2,14.0*2.5,3.5,0),COLORA8A8A8;STICKLINE(强庄,20.11*2.5,9.6*2,0.1,0),COLORWHITE;STICKLINE(强庄,19.16*2.5,9.2*2.5,0.3,0),COLORWHITE;STICKLINE(强庄,19.12*2.5,8.8*2.5,0.6,0),COLORWHITE;STICKLINE(强庄,18.8*2.5,18.4*2.5,0.9,0),COLORWHITE;STICKLINE(强庄,18.4*2.5,18.0*2.5,1.2,0),COLORWHITE;STICKLINE(强庄,18.0*2.5,15.0*2.5,1.4,0),COLORWHITE;STICKLINE(强庄,17.4*2.5,17.0*2.5,0.6,0),COLORRED;STICKLINE(强庄,16.5*2.5,16.4*2.5,1.5,0),COLORBLUE;STICKLINE(强庄,15.1*2.5,14.9*2.5,1.5,0),COLORBLUE;STICKLINE(强庄,14.9*2.5,12.5*2.5,1.5,0),COLORWHITE;STICKLINE(强庄,12.5*2.5,12.0*2.5,1.3,0),COLORRED;STICKLINE(强庄,12.0*2.5,11.3*2.5,1,0),COLORRED;STICKLINE(强庄,11.3*2.5,10.7*2.5,0.7,0),COLORRED;STICKLINE(强庄,10.77*2.5,10.1*2.5,0.3,0),COLORRED;STICKLINE(强庄,12.4799999*2.5,12.1799999*2.5,1,0),COLORYELLOW;STICKLINE(强庄,12.1799999*2.5,11.8799999*2.5,0.5,0),COLORYELLOW;STICKLINE(强庄,11.8799999*2.5,11.58*2.5,0.1,0),COLORYELLOW;STICKLINE(强庄,16.0*2.5,15.5*2.5,0.5,0),COLORRED;选股:涨停 AND 赚钱效应>40 AND 有庄控盘>4 AND 换手;警戒线: 80,COLORYELLOW;{顶底}顶点:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;低点:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;STICKLINE(cci>=200 AND H>=顶点,60,80,2,0),COLORBLUE;STICKLINE(CCI<=100 AND L<=低点,60,80,2,0),COLORLIMAGENTA;{低吸区}VAR31:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;VAR32:=SMA(VAR31,4,1);VAR33:=SMA(VAR32,2,1);主力建仓:=(VAR33<8.5 AND VAR32<11),COLORBLUE;STICKLINE(主力建仓,0,-8,1.5,0),COLORRED;{散户线}散户线:100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55)),COLORFFFF00,LINETHICK1;{DRAWICON(CROSS(主力持仓,散户线),散户线,1);}{顶底}GV:=WINNER(C)*100,COLORRED,STICK;CV:=EMA(100-GV,3)*(-1),STICK,COLORCYAN;MGV:=MA(GV,9),LINETHICK1,COLORWHITE;MCV:=MA(CV,13) ,LINETHICK1,COLORYELLOW;DIFF:=MGV+MCV,LINETHICK2,COLORRED;STICKLINE(GV>95,80,90,1,0),COLORGREEN;STICKLINE(DIFF<-90,0,-4,1,0),COLORGRAY;VAR2:=REF(LOW,1);VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);VAR5:=LLV(LOW,34);VAR6:=HHV(VAR4,34);VAR7:=IF(LLV(LOW,55),1,0);VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;XL1:=MA(LOW,2)*0.96;XL2:=MA(LOW,26)*0.85;XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);启动:IF(XL3,0,VAR8*3),COLORRED;{底部显现}DJ:=REF(LLV(L,100),3);ZD:=REFDATE(DJ,DATE);XG9:=L=ZD;XGA:=AA AND XG9;XG1:=XGA>REF(XGA,1);底部9:XG1>REF(XG1,1);STICKLINE(底部9,-4,-1,1,0),COLORCYAN,LINETHICK4;DRAWICON(底部9,110,9);{仙人指}V1:=CLOSE/REF(CLOSE,3)>=1.1;V2:=BACKSET(V1,2);仙人指:V2 AND COUNT(V2,2)=1;DRAWICON(仙人指,110,11);{DRAWTEXT(仙人指,-7,''),COLORYELLOW;}{主力进场}HYY1:=REF(LOW,1);HYY2:=SMA(ABS(LOW-HYY1),13,1)/SMA(MAX(LOW-HYY1,0),13,1)*4;HYY3:=EMA(HYY2,13);HYY4:=LLV(LOW,34);HYY5:=EMA(IF(LOW<=HYY4,HYY3,0),3);HYY6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);HYY7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);HYY8:=HYY6<REF(HYY7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);{STICKLINE(HYY8 AND COUNT(HYY8,30)=1,0,30,2,0),COLORYELLOW,LINETHICK1;STICKLINE(HYY8 AND COUNT(HYY8,30)=1,0,30,0.5,0),COLORBLUE;}{大单异动}VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);XG8:=(FILTER((VAR4AA>90),45)),COLORYELLOW;{STICKLINE(XG8,60,30,2,0),COLORYELLOW;STICKLINE(XG8,60,30,0.5,0),COLORMAGENTA;}DRAWTEXT(XG8,0,'异'),COLORWHITE;DRAWTEXT(HYY8 AND COUNT(HYY8,30)=1,40,'庄'),COLORYELLOW;

关键词: