通达信强势动能指标公式

时间:2024-02-10 12:09:10    阅读:320
 A0:=((L+H+C*2)/4);中:=EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;下:=EMA(A0,14),COLORRED,LINETHICK2;多空:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK3;{动能节奏}AA:=EMA((2*C+H+L)/4,3);A1:=SLOPE(AA*5-REF(AA,5),5)+C;DIF:=EMA(A1,3) - EMA(A1,13);DEA:=EMA(DIF,3);动能线:IF(C>中 AND C>下 AND C>多空 AND (DIF-DEA)>0,(DIF-DEA),0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.9,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.8,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.7,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线> 0),0,动能线*0.6,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.5,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.4,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.3,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.2,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.1,2,0),COLOR0000FF;{龙头阻击}龙:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(vol,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));龙头阻击:(动能线>0 AND FILTER(龙,19));DRAWICON(龙头阻击,动能线*1.1,25);涨幅:=(C/REF(C,1)-1)*100;去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0 AND NAMELIKE('S*ST')=0;去除停牌:=DYNAINFO(4)>0;去除创业板:=IF(CODELIKE('300') OR CODELIKE('301') ,0,1) ;去除科创板:=IF(CODELIKE('688'),0,1);XG:=去ST AND 去除停牌 AND 去除科创板;MA10:=MA(CLOSE,10);MA54:=MA(CLOSE,54);HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;HJ_9:=FILTER(HJ_8,10);HJ_10:=BARSLAST(HJ_9);HJ_11:=REF(HIGH,HJ_10+2);HJ_12:=REF(HIGH,HJ_10+1);HJ_13:=REF(HIGH,HJ_10);HJ_14:=MAX(HJ_11,HJ_12);HJ_15:=MAX(HJ_14,HJ_13);HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>3.5;HJ_17:=HJ_10<150;HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;HJ_21:=VOL/MA(VOL,5)<3.5;HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;boll:=MA(CLOSE,20);UPPER:=BOLL+2*STD(CLOSE,20);PER:=crOSS(C,UPPER);TPZ1:=MA((L+H+C)/3,5);TPZ2:=HHV(TPZ1,60);TPZ3:=CROSS(C,TPZ2*0.95) OR CROSS(C,TPZ2*0.98) ;TPZ4:=PER AND HJ_25 AND TPZ3;TPZ5:=MA(CLOSE,25)+MA(CLOSE,25)*20/100*0.35;TPZ6:=(MA(MA(H,25),25)-MA(MA(L,25),25))*1+MA(MA(H,25),25);TPZ7:=REF(C<TPZ6 OR C<TPZ5,1) AND C>TPZ6 AND C>TPZ5 ;TPZ8:=TPZ4 OR TPZ7;龙头趋势:动能线>0 AND ((涨幅>8 AND C=H) OR 涨幅>12)AND TPZ8 AND XG AND C/REF(C,1)>1.05 AND REF(C,1)/REF(C,2)<1.04 AND REF(C>3.7,1) AND REF(C<19,1) AND (CAPITAL/100)/10000<=15 AND O/REF(C,1)<1.05 AND C>O,COLORRED;

关键词: