通达信超短强股选股指标公式

2022-04-23 00:32:23    编辑:云才情小编   阅读:8次   点赞:3次
 S1:=IF(NAMELIKE('S'),0,1);
S2:=IF(NAMELIKE('*'),0,1);
S3:=DYNAINFO(17)>0;
S4:=IF(INBLOCK('科创板'),0,1);
S5:=IF(NAMELIKE('C'),0,1);
S6:=IF(INBLOCK('创业板'),0,1);
S7:=IF(INBLOCK('创业板'),1,0);
S8:=IF(CODELIKE('301'),1,0);
S9:=IF(CODELIKE('301'),0,1);
S10:=IF(NAMELIKE('C'),1,0);
去停st1:=S1 AND S2 AND S3 AND S4 AND S5 AND S6;
涨幅:=100*(C-REF(C,1))/REF(C,1);
开幅:=100*(O-REF(C,1))/REF(C,1);
跌幅:=100*(L-REF(C,1))/REF(C,1);
高幅:=100*(H-REF(C,1))/REF(C,1);
昨开幅:=REF((OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100,1);
开换手Z:=DYNAINFO(15)/OPEN/FINANCE(46)*100;
昨换手Z:=REF(V*10000/FINANCE(46),1);
前换手Z:=REF(V*10000/FINANCE(46),2);
开换比:=开换手Z/昨换手Z*100;
板块:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
涨停价:=IF(板块=0.2,ZTPRICE(REF(C,1),0.2),IF(NAMELIKE('S') OR NAMELIKE('*'),ZTPRICE(REF(C,1),0.05),ZTPRICE(REF(C,1),0.1)));
跌停价:=IF(板块=0.2,DTPRICE(REF(C,1),0.2),IF(NAMELIKE('S') OR NAMELIKE('*'),DTPRICE(REF(C,1),0.05),DTPRICE(REF(C,1),0.1)));
去开板:=NOT(OPEN=涨停价);{NOT(OPEN=涨停价)};
涨停:=涨停价=C;
跌停:=跌停价=C;
昨涨停:=REF(涨停,1);
昨跌停:=REF(跌停,1);
G1:=REF(涨停价=O AND 涨停价=C AND L<C,1);
G2:=REF(COUNT(涨停价=C,2)>=1,1);
主板盘:去停ST1 AND 昨涨停=1 AND 开换手Z>0.895 AND RANGE(开幅,2,8);

关键词:
免责声明:本站内容部分来源于网络;如有侵权请告知删除;